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Leaf Cell Layout Considerations

* For very wide transistors

— layout a number of parallel transistors
* I[nstance an vector of transistors in the schematic

« Copy to an array is an efficient way to create
many transistors

— Each transistor should not be wider then 10
um (15 pm)
— Share source and drain regions if possible



Student Chip Example

x: 802.0 ¥: 1189.3 (F) Select: 0 DRD: OFF dx: -14.0 d¥: 3.5 Dist: 15.04 Cmd: Ruler 6

Tools Design Window Create Edit Verify G tivity Opti

E!

i Assura HIT-Kit utilities Help

i

imouse L: Enter Point
| Point at the first point of the ruler:

M: Pop-up Merm F: Toggle L90 /7

 The 20 um wide transistor will cause sparse layout
« Poly resistivity is typ, 11 Q/square => 600 Q to the far end of the gate
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Student Chip Example

X 17103 ¥: 1260.8 (F) Select: 0 DRD: OFF dx: 8343 dy: 72.0 Dist: 897.19 Cmd: Ruler 6

Tools Design Window Create Edit Verify Connectivity Options Routing Assura HIT-Kit utilities Help |

o N
SNy

'mouse L: Enter Point M: Pop-up Menu E: Toggle L0 E/¥

| Paint at the first point of the ruler:

* This layout is even close to dense!




NAND Gate Example

X 1475 ¥i 11.325 (F) Select: 1 DRD: OFF dX: -14.625 dy: 0.400 Dist: 14.6305 Cmd:

Tools Design Window Create Edit Verify Connectivity Options Routing Assura HIT-Kit utilities Help

Guse L: moussSingleSslectPt M. leHiMousePopUp ()

 Size of the left NAND gate: 200 pm?
 Size of right NAND gate: 60 um?

R: hiZoomBhaoluteScale (hibetiurrent¥indow() 0 9)




Current Density

Too high current density will cause
electromigration (transport of metal ions)

Keep RMS current below 0.6 mA to
1 mA per um interconnect width

Peak current should be below 30 mA
Metal wires > 30 um have to be slotted

There are FOUR metal layers — use all of
them

— Gate Poly: 11Q/sqg
— Metal1-3: 70 mQ/sq (typ), 120 mQ/sq (max)
— Metal4: 40 mQ/sq (typ), 100 mQ/sq (max)




Metal Slots

« Large areas of metal can cause layer separation around stress-
sensitive die corners (stress-levels “frozen” into die during
manufacturing)

« Solution: Introduce slots along direction of current flow in wide
metals

« AMS 0.35um slot rules:

Rule | Description Value [um]
WO | Max. METALX 35
width without slots
W1 | Fixed slot width 3
L1 | Min. slot length 30
L2 | Max. slot lenght 300
S1 | Min. spacing for 10
parallel slots
S2 | Min. spacing for 10
slots in sequence g




Contact Resistance

« Contact resistances
— Met1 — Ndiff: typ. 30 Q max 100 Q
— Met1 — Pdiff: typ. 60 Q max 150 Q
— Met1 — Poly: typ. 2 Q max 10 Q

* Via resistance
—Typ 1.2 Q max 3 Q




V|a Current Den3|tv

DDDDDD

Window Create Edit Verify Connectivity Optio ting Assura HIT- Help

If you increase metal wire width to keep current density low.

Think about current density in vias
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V|a Current Den3|tv

Adding extra vias will not cost you anything extral! 3



Bond Pads

Are used to connect your chip to the outside
world

Critical part of the chip assembly

The type of PAD depends on the signal

The PADs are usually provided by the chip vendor
In the lab library there is a few PADs specified

Bond wire

@ ~ 30um
Package or

PCB

1-2mm /

A~ 80-90pm

/7 CHIP
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PADs Included in Lab L

 APRIOP
— Analog Input/Output PAD
— ESD protection included

— Signal accessed in metal 2 on
core-side of the PAD

— Padcap ~1.2pF




PADs Included in Lab Library

« UNPROTPAD
— Analog Input/Output PAD
— No ESD protection

— Signal accessed in metal 2 on
core-side of the PAD

— Suitable for high-speed I/O and
power supply with different voltage
than core




PADs Included in Lab Library

« APRIOWP
— Analog Input/Output PAD
— ESD protection included

— Signal accessed in metal 2 on
core-side of the PAD

— Wide metal 2 from PAD to core
— Padcap ~5pF




PADs Included in Lab Library

- CLK BUFF
— Clock input PAD
— Include ESD and buffers




PADs Included in Lab Library

* INPUTPAD

— Slow input signal PAD
— Includes a small driver
— ESD protection also included




PADs Included in Lab Librar

OUTPUTPAD

— Slow output signal PAD

— Includes a driver with 8mA
current drive strength

— ESD protection included




PADs Included in Lab Library

« VDDGNDCORNER

— Default power supply PAD
for this course

— Provides supply voltage
and ground to the PAD
ring and the Core

— VDD and GND will be
accessed on-chip from the
PAD-ring
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PADs Included in Lab Library

« CORNERFILL

— Fill cell that should be
placed under the
VDDGNDCORNER pad

— Increases fill rate in
POLY1
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PADs Included in Lab Library

 VDDPAD

— Separate power supply PAD
— Includes ESD protection
— Supply to PAD ring and core




PADs Included in Lab Library

« GNDPAD

— Separate ground PAD
— Includes ESD protection
— Ground PAD ring and core




How to Build the PAD Ring

Maximum amount of PADs is 15 (17)
The 2 PADs in the corner are fixed

Corner PADs can not handle large
currents

15 PADs remains for the students to place
“freely”
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How to Build the PAD Ring

* A generic PCB is built
for the measurements

 Requires that the PAD
placement are

somewhat restricted

|: Bias voltage/currents

|: Additional VDD / VSS

Low-speed I/O

High-Speed 1/0 (50
2 differential

4 single-ended

VSSCORE
(GND)

VDDCORE  High-Speed /O (50 Q)

Could also be used as
power supply.
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On-Chip Decoupling

Every switching draws a current from the
power supply

When many devices switch simultaneously,
for example at the clock edges, huge current
spikes might be introduced

This gives voltage fluctuations on-chip that
can cause YOUR chip to malfunction

To filter out these high frequency components
on the power supply a large capacitance
between VDD and GND is used
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On-Chip Decoupling

« Capacitors for decoupling:
— Poly-poly capacitor, cpoly ~0.8fF/um?

— Gate-cap, use a transistor as a decoupling
capacitor. Example: NMOS with the gate
connected to VDD and Drain&Source grounded

— Gate-cap gives more capacitance per area,
~4 5fF/um?

» Use decoupling for all DC-voltages
 How much decoupling is needed?

— Depends on the switching activity

— Depends on how sensitive your design is to power
supply fluctuations
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Common Layout Mistakes

Too small decoupling capacitor!
ONE is NOT enough!

~| Yirtuoso® Layout Reading: grupp31_32_strin Chip layout
X -496.5 ¥: 103.0 (F) Select: 1 dx: dy: Dist: Cmd:

i

e

1

g

2
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How to Connect Your Design

to the Padframe

Digital input/output pads have internal buffers. YOU
have to make sure these buffers are powerful enough
for your design

Do you need a driver in order to drive the driver
included in the I/O pad?

You can also design your own pad driver and use an
analog pad

If you have an external clock, make sure to use an
appropriate clock buffer

Analog inputs/outputs should use the analog pads
without buffers

Use VDD/GND pads for VDD and GND
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Available Components from

PRIMLIB
3.3V NMOS/PMOS

5V NMOS/PMOS

Poly1-Poly2 capacitors (cpoly)

High-resistive poly resistor (rpolyh)
Low-resistive poly resistor (rpoly1 and rpoly2)
Nwell resistor (rnwell)

There are other components as well in
PRIMLIB that can be used. Discuss with your
supervisor before using them!
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Antenna Errors

* Antenna errors occur when a large metal structure is
connected to a gate. When the metal is etched in the
fabrication a large amount of charged might be
Induced in the metal. This can cause the gate to
break if there is no discharging path for high voltages
(like a drain/source or a reversed diode)

« Antenna errors can be fixed by adding a reversed
diode connected to the metal wire causing the
problem. An N+ doped nwell contact will function as a
reversed diode if connected to the substrate. Another
way to solve antenna errors is to build a bridge in
higher or lower layers, and thereby break the long
metal wire connected to the gate
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Antenna Errors

M1 wire

P-substrate %

Long metal wire with reversed diode to substrate.

M2 bridge

1 wire

P-substrate

Long metal wire broken up by a bridge in higher or lower layers
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How to Organize the TOP-LEVEL

* Your Top-Level Iayo&{grlljotuld consist of the

following instances:

— Pad frame

— The core of your design
— Fillpattern (up to Met3)
— Topmet fill

— FIMP and NLDD

 Fill can be created by using scripts

« To avoid fill at certain places, add a blocking
layer
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How to Organize the TOP-LEVEL
Layout

* At the top level

— Always make sure all the instances have
the same origin, preferably (0,0)

— If you accidentally move one cell you can
easily put it back on the right place

« Use the command “Edit in Place” if
necessary, but be careful. Make sure you are
doing your changes in the correct cell
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Common Layout Mistakes

Build dense layouts instead of like this one!

—-| Virtuoso® Layout Reading: grupp5 3_strin chip_bk layout | : |J|
: - : - {F) Select: 0 dx: -77.0 d¥: 1445 Dist: 163.74 Cmd:
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Common Layout Mistakes

Dense layouts to reduce the length of wires!

—4 Yirtuoso® Layout Reading: student_chip1 chipl layout
X: 1090.5 ¥: 1350.0 (F) Select: 0 dX: dy: Dist: cmd: 3
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Common Layout Mistakes
Power grid!

P e e
A N R R R R BRI
R R R R R R P
HEAies RS TR IENRE S R R

F!!i%iii%i,

GND wire
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Chip Verification Flow (1)

DIVA DRC and LVS of local cells
DIVA DRC and LVS of complex cells
ASSURA DRC and LVS of padframe

ASSURA DRC and LVS of chip topcell
(chip core, padframe, decoupling capacitors)
Take care of Antenna errors

Simulate chip topcell
(only extracted capacitances)

Stream out a GDSII file
Stream in the GDSI|I file to a NEW library

LVS of streamed in chip top cell
(compare streamed in layout and original schematic)
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10.
11.
12.

~ W

Chip Verification Flow (2)

Generate Metal Fill
to avoid over- and under etching

Generate FIMP (Field Implant) layer

to avoid weak parasitic transistors under poly interconnects

Generate NLDD (N Lightly Doped Drain) layer

for transistor channel engineering purposes

ASSURA DRC and LVS of chip topcell

(chip core, padframe, decoupling capacitors, Metal
Fill, FIMP, NLDD)

. Stream out a GDSII file
. Stream in the GDSII file to a NEW library
. LVS of streamed in chip top cell

(compare streamed in layout and original schematic)
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Stream-In to NEW library!

Use
File>New=>Library

to create a NEW stream-in library!
This automatically sets library pointers correctly

Example mistake:
Edit > Library Path...

Entered new stream-in
library name with pointer
to original design library!!

OVERWROTE THE
COMPLETE DESIGN!

—|Library Path Editor: ...e/ek/petca/HCMOS8D_613/cdy - ||

File Edit View Help
Libraries

Library Path

eqkb fhome fek henfr fcadencel /5T 018 eqgh

CORELIEBSDHS | /home fek/henfr fcadencel /ST _018/CORELIESDHS local
checkblock | /home ek henfr/cadencel /ST 018/checkblock
adencel /ST 018/ egblock

chipl 2004 h Alome ek /petca/HEMOSED 61
chipl 2004 h Fhome ek /petca HCMOSED E1
chipl 2004 h¥ home /el /petca/HEMOSED 613 chipl 2004 henfr e

C_extr Fhome fek fpetoca HOMOSED BAFRIC extramglo
lihraryl ome /el petcaHCHMOSER F13 1ibhraryl
library2 Fhome fek fpetoa HCHMOSED W3 /libraryl

|

To add a new library definition, type the name in the Library column and the path
to the library in the Path column. Press RETURH to continue adding libraries.

| When done, select the menu ‘File -> Save “s’ to save your edits.




