TSEK03 LAB 2: LNA simulation using Cadence SpectreRF

Ver. 2017-02-15 for Cadence 6 & MMSIM 14

Receiver Front-end

RF Filter \( 50\Omega \) → LNA → Image Filter → LO Mixer
1. Introduction

This lab describes how to use Cadence SpectreRF in Analog Design Environment to simulate parameters that are important in design and verification of Low Noise Amplifiers (LNAs). The lab is based on a Cadence SpectreRF Workshop session and its manual "LNA Design Using SpectreRF" (previous called Application Note) which is found on the course page.

To characterize the LNA, following figure of merits are usually measured or simulated:
1. Power Consumption and Supply Voltage
2. Gain
3. Noise
4. Input and Output Impedance Matching
5. Reverse Isolation
6. Stability
7. Linearity

We will use S-Parameters (SP), Harmonic Balance (hb), and hbnoise analysis available in SpectreRF to simulate above parameter of LNA. Usually there is more than one method available to simulate the desired parameter and it the Application Note, some alternative simulation methods are discussed.

Simulation lab overview:
1. S-Parameter Analysis (sp)
   • Small Signal Gain (S21, GA, GT, GP)
   • Small Signal Stability (Kf and Δ or Bif)
   • Small Signal Noise (SP and Pnoise)
   • Input and Output Matching (S11, S22, Z11, Z22)
2. Large Signal Noise Simulation (hb and hbnoise)
3. Gain Compression (Swept hb and Xdb)
4. IP3 Measurement: hb Analysis with Two Tones

1.1 Lab Instruction

If the lab is not finished in scheduled time slot, you can complete in your own time. If there is any problem, send an email or show up in the office of the instructor. You must answer the questions in the lab manual section 2 before you start the lab, this will help you to comprehend the lab material and simulations methodology.

There are also a questions during the lab after some of the simulations, that you must answer!
1.2 Cadence and PDK Setup Guidelines

1. Please read the complete lab manual and the Cadence Workshop document before you start the software. You will be using Cadence 6 (6.16 + MMSIM 14.1) and AMS 0.35 um CMOS (c35b4) process (PDK) in this lab.

   - Open a terminal session and establish a ssh connection to the ixtab server through the command: ssh ixtab, then input your credentials.
   - Remove any previously loaded Cadence modules (Type module on command prompt and read the instruction. This instruction will guide you how to list, load and remove the modules), or simply start a new terminal window.
   - Create a new directory 'tsek03_lab2' where your simulation data will be stored: mkdir tsek03_lab2.
   - cd tsek03_lab2, then do the rest of the steps from this directory.
   - Load the cadence files: module add cadence/6.16.090
   - Load the AMS PDK files: module add ams/4.10
   - Set variable IUSDIR to your library: setenv IUSDIR . (please note the space and period (.) after IUSDIR)
   - Start cadence with the AMS PDK:
     ams_cds -tech c35b4 -mode fb &
   - You must now choose a technology the first time you run this. In the CIW window: HIT-KIT Utilities → Select Process Option and then choose C35B4C3 PIP VG5 HIRES.

2. When creating schematics, use the RF NMOS transistors from library PRIMLIBRF. The transistor models are valid up till 6 GHz. The models provided in PRIMLIB are only valid up till 1 GHz. The maximum allowable size of NMOS in SpectreRF is 200 um (20 fingers of 10 um or 40 fingers of 5 um). **If you need larger transistors, use two transistors in parallel.**

3. Use analogLib for other active and passive components. In Library Manager click on Show Categories box on the top of window, this will show you the categories of components.

4. There are many views available when you place the symbol in schematic, use *Symbol* or *Spectre* view only.
2. Background preparation

Please read the Application Note “Spectre RF Workshop, LNA Design Using SpectreRF” (SpectreRF_LNA_MMSIM141.pdf), pp. 5-13, available on the course page, and together with your class lecture material and answer the following questions before you attend the lab.

- Define Transducer Power Gain ($G_T$), Operating Power Gain ($G_P$), and Available Power Gain ($G_A$) for a two-port network.

- How can we relate the S-Parameters to the gain, input impedance and output impedance of any two-port network?

- Why is the reverse isolation gain important in the LNA design? Which S-parameter directly characterizes the reverse isolation gain?

- What is Stern stability factor? What is minimum condition of stability for an amplifier?
3. LNA Simulation

3.1 Circuit Simulation Setup

- Load cadence and PDK and start using instructions given in section 1. Make a new library `rf_lab1` in Cadence Library Manager and attach this library to the TECH_C35B4 technology file.
- Create and draw the Schematics LNA as shown in Fig. 1. The components values are listed below.
- M1, M2 = 200 um/0.35 um, choose "number of gates" to have larger width of transistors, Mbias = 60 um/0.35 um
- Ls = 700 pH, Lg = 12 nH, Ld = 6 nH, Rd = 700 Ω

![LNA Circuit Diagram (Source Inductor Degenerated LNA)](image-url)
Before you can place the LNA in a design hierarchy, you must create a symbol: Create, Cellview, From Cellview. You can either use the generic symbol or edit/draw a new one.

Create and draw the Schematics **LNA_testbench** as shown in Fig. 2. The components values are listed below.

- **Input Port in Schematic LNA_testbench**
  - 50 Ohm in *Resistance*
  - 1 in *Port Number*
  - Sine in *Source Type*
  - *frf1* in *Frequency name 1 field*
  - *frf1* in *Frequency 1 field*
  - *prf* in *Amplitude1(dBm) field*
- **Output Port in Schematic LNA_testbench**
  - 500 Ohm in *Resistance*
  - 2 in *Port Number*
- **Component Values in Schematic LNA_testbench**
  - Vdd = 3.3 V, C1, C2= 10 nF, CL= 500 fF

![Fig. 2. LNA Test Bench](image_url)

Open the Schematic LNA_testbench and Select **Launch ➔ ADE L**

Variable values ADE window (Variables➔Copy from Cellview)
  - *frf1* = 2.4G and *prf* = -40
3.2 Small Signal Gain, NF, Impedance Matching and Stability using s-parameters

- In the ADE L window, select Analyses → Choose. The Choosing Analyses window shows:
  - Select \( sp \) for Analysis
  - In \( port \) field click on select and then activate the schematic (if not activated automatically), choose the input port first and then the output port. The names of two selected ports will appear in \( Ports \) field.
  - \( Sweep \) Variable: Frequency
  - \( Sweep \) Range (start-stop): 1G to 5G
  - \( Sweep \) Type: Automatic
  - \( Do \) Noise: Yes
  - Select Input and output ports accordingly by clicking Select and then clicking at the appropriate \( Port \) in Schematic
  - Make sure that \( Enabled \) Box is checked then click OK.

- In the ADE L window click on Simulation → Netlist and Run to start the simulation. Make sure that simulation completes without errors. Check the log in the CIW carefully!

  There may be an error, such as "ERROR (ADE-3036): Errors encountered during simulation". If so, try Setup → Environment. Set Run with 64 bit binary in the ADE L Window and run again.

- Now in the ADE L window click on the Results → Direct plot → Main Form

  Impedance Matching: In the Direct Plot Form window:
  - \( Select \) Function → \( SP \)
  - \( Plot \) Type → Rectangular
  - \( Modifier \) → \( dB20 \)
  - Click \( S11 \) (\( S12, S22, \) and \( S21 \)) and the corresponding parameters are plotted. The results should look similar to Fig. 3.
Fig. 3. LNA s-parameters plots

- Is the matching good at 2.4 GHz? Which s-parameters describes the input and output matching?
  What are "good" values?
• **GT, GA and GP (different type of Gains)**
  - In the *Direct Plot Form* window:
    - *Select Function* → GT, GA and GP (one by one)
    - *Modifier* → dB10
    - Press the *PLOT* button; the result should be similar to Fig. 4.

![Fig 4. GT, GA, and GP](image)

The power gain $G_P$ is closer to the transducer gain $G_T$ than the available gain $G_A$, which means that the input matching network is properly designed, i.e. $s_{11}$ is close to zero.

• **NF (Noise Figure)**
  - In the *Direct Plot Form* window:
    - *Select Function* → NF (and NFmin)
    - *Modifier* → dB10
    - Press *PLOT*.
    - The results are shown in Fig. 5.
Fig. 5. NF and NFmin

- What is NFmin? Is NF good? Is the circuit well designed? (Check the value of NF for the design frequency.)

- **Stability Factor** \( K_f \) (Stern or Rollet) and \( B_1 f \) (intermediate term \( \Delta \))
  - In the *Direct Plot Form* window:
  - *Select Function* \( \rightarrow K_f \) (and \( B_1 f \))
  - Press the PLOT button.
  - The results are shown in Fig. 6.
The Stern stability factor $K$ and $\Delta$ can be plotted in two ways. The stability curves for $K$ and $\Delta$ vs. frequency, Fig. 6, or plotted as load stability circle (LSB) and source stability circle (SSB) in a Smith chart.

Note: You can also measure the $Z$-parameters like $z_{11}$ and $z_{22}$. This might help in the input and output impedance matching circuit design. The input matching can be improved by changing the source degeneration inductor ($L_s$).

- Is the amplifier stable?
3.3 NF by Large Signal Noise Simulation (hb and hbnoise Analysis)

Use the \textit{hb} and \textit{hbnoise} analyses for large-signal and nonlinear noise analyses, where the circuits are linearized around the periodic steady-state operating point (the \textit{Noise} and \textit{SP} analyses are used for small-signal and linear noise analyses, where the circuits are linearized around the DC operating point.)

As the input power level increases, the circuit becomes nonlinear, harmonics are generated, and the noise spectrum is folded. Therefore, you should use the \textit{hb} and \textit{hbnoise} analyses. When the input power level remains low, the NF calculated from the \textit{hbnoise}, \textit{hbsp}, \textit{Noise}, and \textit{SP} analyses should all match.

- Verify the variable values in the ADE L window
  - \textit{fref} = 2.4 GHz
  - \textit{prf} = -20
- In the ADE L window, select \textit{Analyses} \textit{Choose}
- The \textit{Choose Analyses} window shows
  - Select \textit{hb} for Analysis
  - See Fig. 7 for parameter settings
  - Make sure that \textit{Enabled} Box is checked then click OK.
- And again, select \textit{Analyses} \textit{Choose}
  - Select \textit{hbnoise} for Analysis
  - See Fig. 8 for parameter settings
  - \textit{Enable} Box in the bottom should be checked.
  - Click OK
Fig 7. \(hb\) settings
Fig 8. *hbnoise* settings
• In the ADE L window click on Simulation → Netlist and Run to start the simulation. Make sure that simulation completes without errors. Check the log in the CIW carefully!

There may be an error, such as "ERROR (ADE-3036): Errors encountered during simulation". If so, choose Setup → Environment. Set Run with 64 bit binary in the ADE L Window.

• When the simulations is (reasonably) successful (check the log!), in the ADE L window click on the Results → Direct Plot → Main Form

• The Direct Plot Form window appears.
  - Plotting mode → Append
  - Analysis → hbnoise
  - Function → Noise Figure
  - Add to Output → Box Unchecked
  - Click on the Plot Button and confirm that the results are similar to 1Fig. 9.
  - Repeat and add the Input Noise and the Output Noise (Magnitude).

![Fig. 9. NF, Input and Output Noise using hbnoise Analysis](image)

Fig. 9. NF, Input and Output Noise using hbnoise Analysis
• The simulated Noise Figure should be similar to the SP analysis (Fig. 5).
• If you use a high value of \( prf \) (the input power) in the \( hb/hbnoise \) analysis, the LNA can shows some weak nonlinearity and noise as other high harmonics are convoluted.
• Run the simulation again with e.g. \( prf = -10 \text{ dBm} \) and \( -40 \text{ dBm} \) to see this effect!

• The **Noise summary** shows you the contributions of different noise sources in the total noise. This is very powerful feature to focus the effort to improve the noise performance of the device that contributes the maximum noise.
  • Now to see noise contribution in the **ADE L** window, click on the **Results → Print → Noise Summary**
    - **Type → Spot Noise**
    - **Frequency Spot → 2.4G**
    - Click on **Include All Types** button so that all entries are highlighted
    - **Truncate → None**
    - Leave all other field as it is and press **APPLY**
    - The Noise Contribution of Different Sources appears in new window

• Fill in the table below indicating the dominant noise contribution of different components.

<table>
<thead>
<tr>
<th>Component</th>
<th>Contribution [%]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
3.4 Gain Compression (Swept hb and Xdb)

`hb` analysis calculates the operating power gain, which is the ratio of power delivered to the load divided by the power available from the source. This gain definition is the same as that for `G_p`, so the gain from `hb` should match `G_p` when the input power level is low and nonlinearity is weak.

Swept `hb` analysis can be used to calculate the compression point (input or output referred), see Fig. 10.

![Fig. 10 Compression point](image)

- Verify the variable values in the **ADE L** window
  - `frf1 = 2.4 GHz`
  - `prf = -20 dBm`
- In the **ADE L** window, select **Analyses** → **Choose**
- The **Choose Analyses** window shows
  - Select `hb` for Analysis
  - See Fig. 11 for parameter settings
  - Make sure that `Enabled Box` is checked then click OK.
Fig 11. *hb* settings for swept analysis
• In the ADE L window click on Simulation → Netlist and Run to start the simulation, make sure that simulation completes without too many errors in the log.

• The Direct Plot Form window shows
  - Analysis → hb
  - Function → Compression point
  - Format → Output Power
  - Compression point /Curve → Input-referred
  - 1st order Harmonic → 1 2.4G
  - Select the output port on the schematic
  - Compression curve and Compression point are automatically plotted, see Fig. 12

Fig 12. Compression curve and Compression point
• How much is the output-referred compression point?

Starting from MMSIM13.1 (version number for the spectre simulator, the executable that runs the simulations), a dedicated Xdb compression option is integrated in the hb analysis form. It calculates compression points and compression curves directly, without the need for post processing or manual setup of power sweeps. It supports voltage and power-based compression point calculation. It is extremely useful when a large number of compression simulations are needed such as in the corner simulations or MC (Monte Carlo) analysis.

• Verify the variable values in the ADE L window
  ▪ \( frf1 = 2.4 \ \text{GHz} \)
  ▪ \( prf = -20 \ \text{dBm} \)

• In the ADE L window, select Analyses \rightarrow Choose

• The Choose Analyses window shows
  ▪ Select hb for Analysis
  ▪ See Fig. 13 for general parameter settings
  ▪ Check the Compression box and enter additional parameters according to Fig. 14
  ▪ Make sure that Enabled Box is checked then click OK.

• In the ADE L window click on Simulation \rightarrow Netlist and Run to start the simulation, make sure that simulation completes without too many errors in the log.

• In the ADE L window, select Results \rightarrow Direct Plot \rightarrow Main Form

• The Direct Plot Form window shows
  ▪ Analysis \rightarrow xdb
  ▪ Function \rightarrow Power/voltage/gain
  ▪ Plot
  ▪ Compression curve and Compression point are plotted, see Fig. 15
Fig 13. *hb* settings
Fig 14. Compression point settings in $hb$ analysis

Fig 15. Compression curve and Compression point using $Xdb$ analysis.

3.5 IP3 Measurement: $hb$ Analysis with Two Tones
A two-tone test is normally used to measure an IP3 curve where the two input tones are $\omega_1$ and $\omega_2$. Since the first-order components grow linearly and third-order components grow cubically, they eventually intercept as the input power level increases. The IP3 is defined as the crossing point of the power for the 1st order tones, $\omega_1$ and $\omega_2$, and the power for the 3rd order tones, $2\omega_1 - \omega_2$ and $2\omega_2 - \omega_1$, on the load side, see Fig 16.

![Fig 16. IP3.](image)

There are several simulation methods to measure IP3. In this lab, we will use $hb$ analysis with two tones. In the Application note, you can read about other methods to calculate IP3 (see sections Lab 4 and Lab 6).

The $hb$ analysis method treats both tones as large signals and uses an $hb$ analysis with two tones. We must therefore change the settings of the input port/signal source to a two-tone source.

- Change the Input Port Parameters in Schematic Window
  - 50 Ohms in **Resistance**
  - 1 in **Port Number**
  - **Sine** in **Source Type**
  - $frf1$ in **Frequency name 1 field**
  - $frf1$ in **Frequency 1 field**
  - $prf1$ in **Amplitude 1 (dBm) field**
  - Check box **Display Second Sinusoid**
  - $frf2$ in **Frequency name 2 field**
  - $frf2$ in **Frequency 2 field**
  - $prf2$ in **Amplitude 2 (dBm) field**
• Verify the variable values in the ADE L window
  - \( f_{rf1} = 2.4 \text{ GHz} \)
  - \( f_{rf2} = 2.44 \text{ GHz} \)
  - \( prf = -40 \text{ dBm} \)

• In the ADE L window, select Analyses \( \Rightarrow \) Choose

• The Choosing Analyses window shows
  - Select \( hb \) for Analysis
  - See Fig. 17 for the parameter settings
  - Make sure that Enabled Box is checked then click OK.

• Click OK In the ADE L window click on Simulation \( \Rightarrow \) Netlist and Run to start the simulation, make sure that simulation completes without errors.

• In the ADE L window, select Results \( \Rightarrow \) Direct Plot \( \Rightarrow \) Main Form

• The Direct Plot Form window shows
  - Function \( \Rightarrow \) IPN Curves
  - Select Port (Fixed R (Port))
  - Single Point Input Power Value \( \Rightarrow \) -40 dB
  - Highlight Input Referred IP3
  - Order \( \Rightarrow \) 3rd
  - 3\text{rd Order Harmonic} \( \Rightarrow \) 2.48G
  - 1\text{st Order Harmonic} \( \Rightarrow \) 2.4G

• Activate the Schematic Window and click on Output port to view the results as shown in Fig. 18.
Fig 17. *hb* settings for two-tone analysis
This concludes the LNA simulation lab!