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Ultiboard Tutorial
This tutorial will familiarize you with Ultiboard’s basic functions. 

Introduction to the Ultiboard Interface 
Ultiboard is the PCB layout application of Circuit Design Suite, a suite of EDA (Electronics 
Design Automation) tools that assists you in carrying out the major steps in the design flow. 
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Instruktioner för TSTE93
- Starta programmet med "Start/All Programs/NI Ultiboard 14.0"
- Exempelfilerna som nämns i övningarna nås med "File/Open samples…/Getting Started/"
  + Använd helst din egen Multisim-konstruktion då exemplen kan vara ändrade
  + Annars kopierar du filerna innan du använder dem för att inte ändra i originalen
- Tillvalen "Connection Machine" och "Autoplace" saknas i den aktuella installationen
  + Hoppa därför över övningarna "Connection Machine Trace" och "Auto Part Placement" 
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Ultiboard is used to lay out and route printed circuit boards, perform certain basic mechanical 
CAD operations, and prepare boards for manufacturing. It also provides automated parts 
placement and wire routing. 

Ultiboard User Interface 
The Ultiboard user interface includes the following elements: 

Refer to the table below as needed: 

1 Menu Bar
2 Standard Toolbar
3 Select Toolbar
4 Draw Settings Toolbar

5 View Toolbar
6 Main Toolbar
7 Autoroute Toolbar

8 Status Bar
9 Workspace
10 Spreadsheet View

11 Design Toolbox
12 3D Preview
13 Birds Eye View

Element  Description

1 Menu Bar Contains the commands for all functions. 

2 Standard toolbar Contains buttons for commonly-performed functions such as 
Save, Print, Cut, and Paste. 
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Overview 
The following sections show you how to place the parts and traces for the circuit described in 
the Multisim Tutorial section. 

If you wish to skip steps, or only complete specific sections of this tutorial, you can use the 
different tabs, found in ...\Circuit Design Suite <version>\samples\
Getting Started\GettingStarted: 

• Tab GS1—The design with all components imported from Multisim and placed outside of
a default board outline. This is the starting point for this tutorial.

• Tab GS2—The design with the imported components placed on the correctly sized board.

• Tab GS3—The design with the imported components placed on the board, and four holes
placed from the database.

• Tab GS4—The design with all of the parts placed, and all of the copper (traces) routed.

• Tab GS5—The design with some parts placed and locked. Locked parts are not moved
during autoplacement.

3 Select toolbar As you add more parts and traces to a board, it can become 
difficult to select only those which you want to use. This toolbar 
contains buttons used to control selections. 

4 Draw Settings 
toolbar

This is where you select the layer, thickness and unit of measure 
of a line or object that is being drawn. It also contains buttons 
for functions that control the appearance of lines and shapes 
drawn on a layer. 

5 View toolbar Contains buttons for modifying the way the screen is displayed. 

6 Main toolbar Contains buttons for common board design functions. 

7 Autoroute toolbar Contains autorouting and part placement functions. 

8 Status Bar Displays useful and important information. 

9 Workspace This is where you lay out the PCB. 

10 Spreadsheet View This allows fast advanced viewing and editing of parameters 
including part details such as shapes, reference designators, 
attributes and design constraints. 

11 Design Toolbox Use to navigate through project files and show, hide or dim 
different elements of the design. 

12 3D Preview Displays a three-dimensional preview of the board. 

13 Birds Eye View Displays an “aerial view” of the design and lets you easily 
navigate around the workspace. 

Element  Description
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Helpful tips are indicated by an icon in the left column, for example: 

Tip You can access the online help at any time by pressing F1 on your keyboard, or 
by clicking the Help button in a dialog box. 

Opening the Tutorial 
Complete the following steps to open the tutorial file: 

1. Launch Ultiboard, select File»Open samples and double-click on the Getting Started
folder to open it.

2. Select GettingStarted and click Open.

The project file is loaded into Ultiboard.

Tip For instructions on transferring a design from Multisim to Ultiboard, refer to 
the Multisim Help and the Ultiboard Help. 

3. Select design GS1.

Tip To select a design from the project (for example, GS1), click on its tab, or click 
on its name in the Projects tab of the Design Toolbox. 
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Creating a Board Outline 
There is a default board outline, however, you can create one that is a more suitable size for the 
parts in this design in one of the following ways:

• Draw a board outline using the drawing tools.

• Import a DXF file.

• Use the Board Wizard.

Complete the following steps to experiment with the Board Wizard: 

1. Double-click on Board Outline in the Layers tab to make it the active layer.

2. Click on the existing board outline in the GS1 design and press Delete on the keyboard.

3. Choose Tools»Board wizard.

4. Select Change the layer technology to make the Technology options available.

5. Select Multi-layers constructed with double-sided boards (layer pairs), and click Next.

6. Change the number of Layer pairs to 2 and leave Blind vias unchecked.

7. Click Next.

In the Board Wizard - Shape of Board dialog box:

a. Confirm that Units is set to mil.

b. Confirm that the Reference point is set to Bottom-left for Alignment.

c. Confirm that the Rectangular option is selected in Board shape and size.

d. Set the Width to 3000 and the Height to 2000.

e. Set the Clearance to 5.00000.

This is the distance from the edge of the board that is to be kept free of parts or any
other elements.

8. Click Finish.

The board outline is placed on your design.

Note For complete details on the Board Wizard, refer to the Ultiboard Help. 

9. Click anywhere on the board outline in the workspace and drag the board to a location just
below the row of parts.
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Complete the following steps to change the reference point: 

1. Select Design»Set reference point.

The reference point is attached to your cursor.

2. Move the cursor the the lower-left corner of the board outline and click to place it.

Placing Parts 
You can place parts on your GS1 board in several different ways: 

• Select one or more parts from outside the board outline and drag them into place.

• Use the Parts tab in the Spreadsheet View to locate parts and place them.

• Select and place parts from the database.

Tip Use the Place»Unplace parts command to remove all non-locked parts from 
the PCB and experiment with a different placement technique. 

Dragging Parts from Outside the Board Outline 
By default, parts are placed outside the board outline when you open a netlist from Multisim. 

Complete the following steps to drag U1 from outside the board outline: 

1. Double-click the Copper Top layer in the Design Toolbox to make it the active layer.

2. Find U1 in the collection of parts outside the board outline. To make this easier, use the
mouse wheel to zoom in until you can see U1.
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Tip You can also search for a part with the Edit»Find command. While this 
command works much like a Find function in other applications, it also allows you 
to search for a part by name, number, shape, value, or by all variables. Refer to the 
Ultiboard Help for details. 

3. Click on U1 (the 7-segment display) and drag it to the location shown in the figure below. 

As you move the part, the ratsnest moves with it. A ratsnest is a straight line connection 
between pads, indicating their connectivity. It is not a trace. 

U1 remains selected. This is an important point for Ultiboard that holds throughout the 
application—you need to explicitly end any particular action. 

Click elsewhere on the workspace to de-select the part. 
 

4. Go to the Parts tab in the Spreadsheet View and scroll to U1. 

Notice that the green dot beside the part is slightly brighter—this indicates that the part has 
been placed. 
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Dragging Parts from the Parts Tab 
Complete the following steps to drag parts from the Parts tab: 

1. In the Parts tab, scroll down to J1. 
 

2. Click on the green dot beside J1 in the table and drag the component from the Parts tab 
onto the workspace. 

J1 is attached to the cursor. 

3. Drop J1 on the left edge of the board, approximately in the middle. 

In the Parts tab, J1’s green dot is now slightly brighter, indicating that the part has been 
placed. 

Placing the Tutorial Parts
Using any method or combination of methods, lay out the design as shown below. 

Tip You can open the next design file in the project, GS2, which has already been 
set up this way. 

The design should look like this: 
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Placing Parts from the Database 
In addition to placing parts imported as part of your design, you can place parts directly from the 
database. The following uses this method to place the mounting holes. 

Complete the following steps to place parts from the database: 

1. Choose Place»From database. 

2. The Get a Part From the Database dialog box opens.  

3. In the Database panel, expand the Ultiboard Master»Through Hole Technology Parts 
category and select the Holes category. 

The parts appear in the Available parts panel. 

4. In the Available parts panel, select the HOLE35 part. 

The part displays in the Preview panel. 
 

5. Click OK. 

The Get a Part From the Database dialog box disappears, and the Enter Reference 
Designation for Part dialog box displays. 

6. Enter the RefDes for shape HOLE35 (H1) and Value (HOLE) and click OK. 

7. Move the cursor over the board. 

The part is attached to the cursor. 
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8. Move the hole to the top-left corner, and click to drop it on the board. 

The Enter Reference Designation for Part dialog box reappears, with the RefDes for 
shape HOLE35 automatically incremented to H2. 

9. Enter the value (HOLE) and click OK to place the next mounting hole in the top right 
corner. 

10. Repeat to place H3 in the bottom right corner, and H4 in the bottom left corner. 

11. Click Cancel to stop, and click Cancel again. 

The Get a Part From the Database dialog box closes. 
 

Moving Parts
You can use similar methods for moving parts as you do for placing them. 

To select a part already on the board, click on it. 

To specify the X/Y coordinates to where the selected part is to move, press * on the numeric 
keypad. 

Or, select a placed part in the Parts tab of the Spreadsheet View (indicated by a bright green 
dot beside it) and drag it to a new location. 

Tip A part’s label and pads are separate elements from its shape. When selecting a 
part on the board, be sure to select the whole part, not just the label or pads. Use the 
Selection Filters to assist with this. Refer to the Ultiboard Help for more 
information. 

Tip Once a part is selected, you can also move it around on the board by pressing 
the arrow keys on your keyboard. 
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To select a group of parts and move them together, do one of the following: 

• Hold <Shift> and click on more than one part. 

• Drag a box around several parts. 

All the selected parts will move together when you drag the cursor. 

You can use the Edit»Align commands to align the edges of selected parts or to space them 
relative to each other. 

Use the Edit»Align commands to align the mounting holes you just placed: 

1. Select H1 and hold <Shift> to select H2. 

2. Choose Edit»Align»Align top. 

If H2 was not originally placed exactly in line with H1, you will see it move. 

3. Click on an empty space on the board to clear the selection, then select H2 and H3. 

4. Choose Edit»Align»Align right. 

5. Continue in this manner to align the bottoms of H3 and H4, and the left sides of H1 and H4. 

Placing Traces 
You have the following options for placing traces: 

• Manual trace. 

• Follow-me trace. 

• Connection machine trace. 

A manual trace is placed exactly as you specify, even running through a component or trace if 
that is the path you set. 

A follow-me trace automatically draws a valid trace between the pins you select with your 
mouse movements—you can move from pin to pin, leaving a valid trace. 

A connection machine trace automatically joins two pins by the most efficient route, though you 
have the option of changing it.

As you place a trace, and before you click to fix it in place, you can remove a segment by backing 
up over it. 

Each time you click while placing a manual trace, or each time a follow-me trace or connection 
machine trace changes direction, a separate segment of that trace is created. 

Tip When performing operations on traces, be sure to select either the appropriate 
segment or the whole trace. 
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Placing a Manual Trace 
You can continue with the design you have been working on, or open GS3. 

Be sure you are on the Copper Top layer before beginning—Copper Top must be highlighted 
in red in the Layers tab of the Design Toolbox. 

Complete the following steps to place a trace manually: 

1. Choose Place»Line. 

Tip The Line command creates a line on any layer. The results differ depending on 
the layer selected. For example, if the selected layer is silkscreen, a line is created on 
the silkscreen layer of the PCB. If the selected layer is a copper layer, then the line is 
actually a trace. 

2. Locate J1, toward the left-hand part of the board and find the start pin shown below: 
 

Tip If you have trouble locating the part, select the part in the Parts tab and click 
the Find the selected part button. The part is selected in the workspace. If necessary, 
zoom in further using the mouse wheel. 

3. Click on the pin specified in the above step. 

Ultiboard highlights all the pins that are part of the same net as the pin you clicked on with 
an X. These indicate which pins to connect to match the connectivity from your schematic 
and in the netlist. 

1 Part J1 2 Start Pin
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4. Move the cursor in any direction. 

A green line (the trace) is attached to the selected pin. Each time you click, you anchor the 
trace segment, as shown in the figure below (2). 

5. Click to anchor the trace and on the destination pin as shown below. 
 

6. Right-click and choose Cancel to stop placing traces. 

7. Click the Select button on the Main toolbar to exit line-placing mode.  

1  Pins in the Same Net  

1 Trace 2 Click to anchor trace 3 Destination Pin
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Placing a Follow-me Trace 
Complete the following steps to place a follow-me trace: 

1. Choose Place»Follow-me.  

2. Click on the top pin of J1. 

3. Click on the pin indicated by the “X” on U4. 

Ultiboard draws the trace for you. 

4. Right-click and choose Cancel to stop placing traces. 

Connection Machine Trace 
Complete the following steps to place a Connection Machine trace: 

1. Choose Place»Connection Machine.  

2. Click on the segment of the ratsnest indicated below. 
 

3. Move your cursor. 

As the cursor moves, Ultiboard displays various trace placement options. 

1 Click Ratsnest  
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4. Click to fix the trace when you see the route you want. There is no need to click on the 
ratsnest or the destination pin. 

 

5. Right-click to end trace placement. 

Auto Part Placement 
As well as placing parts as described earlier in this section, you can use Ultiboard’s automatic 
part placement functionality. 

Tip Before autoplacing parts, pre-place and lock any parts that you do not wish to 
be moved during the autoplacement process. (The mounting holes, and U1, J1, S1, 
S2, and LED 1 in GS5 have been pre-placed and locked). For details on locking parts, 
refer to the Ultiboard Help. 

Complete the following steps to autoplace the parts in Getting Started: 

1. Open the GS5 design in Ultiboard. 

2. Select Autoroute»Autoplace parts. 

The parts are placed on the circuit board. 

1 Trace Segments Appear Between Pins  
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Autorouting Traces 
You can place traces in Ultiboard using the methods described earlier in this section, or 
automatically route the traces as described below. 

Complete the following steps to autoroute the traces in Getting Started: 

1. Open the GS3 design in Ultiboard. 

2. Select Autoroute»Start/resume autorouter. 

The workspace switches to Autorouter Mode and trace autorouting begins. 

As autorouting proceeds, you will see traces being placed on the board. When autorouting 
is complete, Autorouter Mode closes and you are returned to the workspace. 

 

The autorouter can be stopped at any time and you can make manual changes as desired. When 
you restart the autorouter, it will continue with the changes you made. Remember to lock any 
traces that you have placed manually and do not wish to be moved by the autorouter. 

Tip Use the Routing Options dialog box to modify autoplacement and autorouting 
options. Refer to the Ultiboard Help for details. 
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Preparing for Manufacturing/Assembly 
Ultiboard can produce many different output formats to support your production and 
manufacturing needs. The following sections explain the functions performed to output your 
board for production and documentation purposes.

Cleaning up the Board 
Before sending the board for manufacturing, you should clean up any open trace ends (trace 
segments that do not have any terminating connections in the design) and unused vias. 

To delete any open trace ends, open the GS4 design and choose Edit»Copper delete»Open 
trace ends. 

To delete any unused vias, select Design»Remove unused vias. This deletes all vias that do not 
have any trace segments or copper areas connected to them.

Adding Comments 
Comments can be used to show engineering change orders, to facilitate collaborative work 
among team members, or to allow background information to be attached to a design.

You can pin a comment to the workspace, or directly to a part. When a part with an attached 
comment is moved, the comment also moves. 

Refer to the Ultiboard Help for details.

Exporting a File 
You can export a number of file types, including Gerber. An exported file contains complete 
information describing how a finished board is to be manufactured. 

Refer to the Ultiboard Help for details. 
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Viewing Designs in 3D 
You can use the 3D View to see what the board looks like in three dimensions at any time during 
the design. 

Refer to the Ultiboard Help for details. 




